Online Booking Temporarily Offline
Incident Report for Aesthetic Record Status
Resolved
Online booking is restored. We appreciate your patience. If you need anything at all don't hesitate to reach out via chat, or email us at info@aestheticrecord.com.
Posted Sep 02, 2021 - 14:53 EDT
Identified
We’ve temporarily disabled online booking for all Aesthetic Record customers in order to allow our team to more quickly resolve issues that have been reported. We will keep you posted, and hope to have it back online very soon.
Posted Sep 01, 2021 - 08:18 EDT
This incident affected: Online Booking.