SMS is Temporarily Out of Service
Incident Report for Aesthetic Record Status
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 07:38 EDT
Investigating
We're currently investigating the disutriptance of SMS for booking and inbox.
Posted Sep 13, 2022 - 21:23 EDT
This incident affected: SMS.